Photo uploads to past cruises, odd occurrence

When I try to upload a photo to a past cruise on my Profile page, I click on the UPLOAD PHOTOS button and it takes me to the upload page of a completely different cruise. (Click on a Princess cruise in 2012... takes me to a Celebrity cruise in 2015.) Anyone else having this problem? I either get that response or I get...

Oops!

Looks like the page you requested is lost at sea.

6 Answers

Technology glitches do occur and at the oddest times it seems. Have you checked with the moderators of this site?

I sent an email a couple of weeks ago, haven't heard anything... I wonder if I am the only one experiencing the problem.

No, others have had issues so maybe those that did can view your post and respond with some assistance. Hang in there.

Hi, we are looking into this issue for you! Thanks for bringing it to our attention.

I had that same issue about after my cruise last May. Unfortunately never resolved so I was never able to load my photos into my review.

Same issue, just tried to upload and got the same error message.

Reply

*Cruiseline.com is not a booking agent or travel agency, and does not charge any service fees to users of our site. Our partners (travel agencies and cruise lines) provide prices, which we list for our users' convenience. Cruiseline.com does not guarantee any specific rates or prices. While prices are updated daily, please check with the booking site for the exact amount. Cruiseline.com is not responsible for content on external web sites.

Back to Top