"Ships Forum"

Anyone having trouble viewing the Ships Forum? This is what I see whether I log in on Chrome (my usual) or Internet Explorer when I am on my laptop. 

 

9 Answers

We're looking into it! Thanks for bringing the issue to our attention. 

Not just you -- I go the same thing. Looks like Sarah is right on top of it though.

On and off all day been having problems with various sites, not allowing log-in, being thrown off in  the middle of something, or just were the site looks scrambled but refreshing does nothing.

Perhaps there is a hub or nexus problem.

I think the team is in the process of reformatting the site a bit at a time.

I wonder why they would want to mess with perfection, but it still seems to get better!Love

Yep

I only use my iPad or iPhone when I'm on the forum and haven't had any problems at all. It's great to see the crew is working quickly to resolve any problems with the other browsers.

I use Firefox and am experience no problems whatsoever.

I tried using Google Chrome on our PC and the site was fine. Hopefully everyone else is able to access it ok now too.

I'm using Firefox, but having the same issue. Got the same thing.

Reply

*Cruiseline.com is not a booking agent or travel agency, and does not charge any service fees to users of our site. Our partners (travel agencies and cruise lines) provide prices, which we list for our users' convenience. Cruiseline.com does not guarantee any specific rates or prices. While prices are updated daily, please check with the booking site for the exact amount. Cruiseline.com is not responsible for content on external web sites.

Back to Top